Back to overview
Resolved
Inventory Management Updates and Upgrades
Jul 17, 2026 at 1:35am UTC
–
Jul 17, 2026 at 6:00am UTC
Affected services
Inventory Service
Square POS
Resolved
Jul 17, 2026 at 6:00am UTC
Maintenance ended
Affected services
Created
Jul 17, 2026 at 1:35am UTC
Inventory management will be undergoing upgrades to the system and core architecture. This maintenance is expected to be completed without any downtime and will also impact POS integration.
Affected services